H3C交换机典型(ACL)访问控制列表配置实例

腾讯视频/爱奇艺/优酷/外卖 充值4折起

一、组网需求
1.通过配置基本访问控制列表,实现在每天8:00~18:00时间段内对源IP为10.1.1.2主机发出报文的过滤; www.
2.要求配置高级访问控制列表,禁止研发部门与技术支援部门之间互访,并限制研发部门在上班时间8:00至18:00访问工资查询服务器;
3.通过二层访问控制列表,实现在每天8:00~18:00时间段内对源MAC为00e0-fc01-0101的报文进行过滤。

二、组网图

三、配置步骤
H3C 3600 5600 5100系列交换机典型访问控制列表配置
共用配置
1.根据组网图,创建四个vlan,对应加入各个端口
<H3C>system-view
[H3C]vlan 10
[H3C-vlan10]port GigabitEthernet 1/0/1
[H3C-vlan10]vlan 20
[H3C-vlan20]port GigabitEthernet 1/0/2
[H3C-vlan20]vlan 30
[H3C-vlan30]port GigabitEthernet 1/0/3
[H3C-vlan30]vlan 40
[H3C-vlan40]port GigabitEthernet 1/0/4
[H3C-vlan40]quit
2.配置各VLAN虚接口地址
[H3C]interface vlan 10
[H3C-Vlan-interface10]ip address 10.1.1.1 24
[H3C-Vlan-interface10]quit
[H3C]interface vlan 20
[H3C-Vlan-interface20]ip address 10.1.2.1 24
[H3C-Vlan-interface20]quit
[H3C]interface vlan 30
[H3C-Vlan-interface30]ip address 10.1.3.1 24
[H3C-Vlan-interface30]quit
[H3C]interface vlan 40
[H3C-Vlan-interface40]ip address 10.1.4.1 24
[H3C-Vlan-interface40]quit
3.定义时间段
[H3C] time-range huawei 8:00 to 18:00 working-day
需求1配置(基本ACL配置)
1.进入2000号的基本访问控制列表视图
[H3C-GigabitEthernet1/0/1] acl number 2000
2.定义访问规则过滤10.1.1.2主机发出的报文
[H3C-acl-basic-2000] rule 1 deny source 10.1.1.2 0 time-range Huawei
3.在接口上应用2000号ACL
[H3C-acl-basic-2000] interface GigabitEthernet1/0/1
[H3C-GigabitEthernet1/0/1] packet-filter inbound ip-group 2000
[H3C-GigabitEthernet1/0/1] quit
需求2配置(高级ACL配置)
1.进入3000号的高级访问控制列表视图
[H3C] acl number 3000
2.定义访问规则禁止研发部门与技术支援部门之间互访
[H3C-acl-adv-3000]rule 1 deny ip source 10.1.2.0 0.0.0.255 destination 10.1.1.0 0.0.0.255
3.定义访问规则禁止研发部门在上班时间8:00至18:00访问工资查询服务器
[H3C-acl-adv-3000] rule 2 deny ip source any destination 129.110.1.2 0.0.0.0 time-range Huawei
[H3C-acl-adv-3000] quit
4.在接口上用3000号ACL
[H3C-acl-adv-3000] interface GigabitEthernet1/0/2
[H3C-GigabitEthernet1/0/2] packet-filter inbound ip-group 3000
需求3配置(二层ACL配置)
1.进入4000号的二层访问控制列表视图
[H3C] acl number 4000
2.定义访问规则过滤源MAC为00e0-fc01-0101的报文
[H3C-acl-ethernetframe-4000] rule 1 deny source 00e0-fc01-0101 ffff-ffff-ffff time-range Huawei
3.在接口上应用4000号ACL
[H3C-acl-ethernetframe-4000] interface GigabitEthernet1/0/4
[H3C-GigabitEthernet1/0/4] packet-filter inbound link-group 4000
2 H3C 5500-SI 3610 5510系列交换机典型访问控制列表配置
需求2配置
1.进入3000号的高级访问控制列表视图
[H3C] acl number 3000
2.定义访问规则禁止研发部门与技术支援部门之间互访
[H3C-acl-adv-3000]rule 1 deny ip source 10.1.2.0 0.0.0.255 destination 10.1.1.0 0.0.0.255
3.定义访问规则禁止研发部门在上班时间8:00至18:00访问工资查询服务器
[H3C-acl-adv-3000] rule 2 deny ip source any destination 129.110.1.2 0.0.0.0 time-range Huawei
[H3C-acl-adv-3000] quit
4.定义流分类
[H3C] traffic classifier abc
[H3C-classifier-abc]if-match acl 3000
[H3C-classifier-abc]quit
5.定义流行为,确定禁止符合流分类的报文
[H3C] traffic behavior abc
[H3C-behavior-abc] filter deny
[H3C-behavior-abc] quit
6.定义Qos策略,将流分类和流行为进行关联
[H3C]qos policy abc
[H3C-qospolicy-abc] classifier abc behavior abc
[H3C-qospolicy-abc] quit
7.在端口下发Qos policy
[H3C] interface g1/1/2
[H3C-GigabitEthernet1/1/2] qos apply policy abc inbound
8.补充说明:
l acl只是用来区分数据流,permit与deny由filter确定;
l 如果一个端口同时有permit和deny的数据流,需要分别定义流分类和流行为,并在同一QoS策略中进行关联;
l QoS策略会按照配置顺序将报文和classifier相匹配,当报文和某一个classifier匹配后,执行该classifier所对应的behavior,然后策略执行就结束了,不会再匹配剩下的classifier;
l 将QoS策略应用到端口后,系统不允许对应修改义流分类、流行为以及QoS策略,直至取消下发。

四、配置关键点
1.time-name 可以自由定义;
2.设置访问控制规则以后,一定要把规则应用到相应接口上,应用时注意inbound方向应与rule中source和destination对应;
3.S5600系列交换机只支持inbound方向的规则,所以要注意应用接口的选择;

H3C交换机基于MAC地址VLAN配置教程

11/27 17:29
对于不是很常用的MAC VLAN,许多读者都感到很陌生,读者QQ群中也经常见到有读者提到这方面的问题,希望我给予解答。现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所帮助。如要全面了解Cisco和H3C交换机的MAC VLAN相关知识和配置方法,请参见Cisco/H3C交换机配置与管理完全手册》(第二版)。 19.6 H

思科路由器反向访问控制列表配置

07/10 02:22
在172.16.4.0/24网段中的计算机都是服务器,我们通过反向ACL设置保护这些服务器免受来自172.16.3.0这个网段的病毒攻击。 配置实例:禁止病毒从172.16.3.0/24这个网段传播到172.16.4.0/24这个服务器网段。 access-list 101 permit tcp 172.16.3.0 0.0.0.255 172.16.4.0 0.0.0.255 established Cisco 模拟器 定义ACL101,容许所有来自172.16.3.0网段的计算机访问17

H3C交换机命令大全

09/25 13:28
H3C交换机命令大全: 1.system-view 进入系统视图模式 2.sysname 为设备命名 3.display current-configuration 当前配置情况 4.language-mode Chinese|English 中英文切换 5.interface Ethernet 1/0/1 进入以太网端口视图 6.port link-type Access|Trunk|Hybrid 设置端口访问模式 7.undo shutdown 打开以太网端口 8.shutdown 关闭以太

访问控制列表ACL及配置教程

11/22 21:25
访问控制列表: ACL: (accesscontrollist) 适用所有的路由协议:IP,IPX,AppleTalk 控制列表分为两种类型: 1.标准访问控制列表:检查被路由数据包的源地址、1~99代表号 2.扩展访问控制列表:对数据包的源地址与目标地址进行检查。 访问控制列表最常见的用途是作为数据包的过滤器。 其他用途;可指定某种类型的数据包的优先级,以对某些数据包优先处理 识别触发按需拨号路由(DDR)的相关通信量 路由映射的基本组成部分 ACL能够用来: 提供网络访问的基本安全手段 访问

Linux系统配置 Linux访问控制列表(ACL)的权限控制方法

10/07 20:17
使用拥有权限控制的Liunx,工作是一件轻松的任务。它可以定义任何user,group和other的权限。无论是在桌面电脑或者不会有很多用户的虚拟Linux实例,或者当用户不愿意分享他们之间的文件时,这样的工作是很棒的。然而,如果你是在一个大型组织,你运行了NFS或者Samba服务给不同的用户,然后你将会需要灵活的挑选并设置很多复杂的配置和权限去满足你的组织不同的需求。 Linux(和其他Unix等POSIX兼容的操作系统)有一种被称为访问控制列表(ACL)的权限控制方法,它是一种权限分配之外的

如何在Linux下设置访问控制列表(ACL)来控制用户的权限

12/07 11:51
Linux下的访问控制列表(ACL)主要用来控制用户的权限,可以做到不同用户对同一文件有不同的权限,那么具体要如何操作呢?下面小编就教你如何在Linux下设置访问控制列表(ACL)来控制用户的权限。 使用拥有权限控制的Liunx,工作是一件轻松的任务。它可以定义任何user,group和other的权限。无论是在桌面电脑或者不会有很多用户的虚拟Linux实例,或者当用户不愿意分享他们之间的文件时,这样的工作是很棒的。然而,如果你是在一个大型组织,你运行了NFS或者Samba服务给不同的用

H3C交换机配置备份与恢复(web界面/命令行形式)

05/02 15:56
局域网维护中,有时候我们需要对网络设备的配置进行备份与还原。 相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。 还原的时候再复制命令到交换机中从新运行。这种方法当然也是可行的,但是当交换机的配置特别多,又比较复杂的情况下,这种方法就不太合适了。 下面我介绍一种整体导入和导出H3C交换机配置的方法。 本次实验采用的设备和软件有:H3

h3c交换机配置命令整理分享

11/05 18:36
华为3COM交换机配置命令详解 1、配置文件相关命令 [Quidway]display current-configuration ;显示当前生效的配置 [Quidway]display saved-configuration ;显示flash中配置文件,即下次上电启动时所用的配置文件 <Quidway>reset saved-configuration ;檫除旧的配置文件 <Quidway>reboot ;交换机重启 <Quidway>display ver

H3C交换机如何配置的备份与恢复

05/02 18:06
局域网维护中,有时候我们需要对网络设备的配置进行备份与还原。 相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。 还原的时候再复制命令到交换机中从新运行。这种方法当然也是可行的,但是当交换机的配置特别多,又比较复杂的情况下,这种方法就不太合适了。 下面我介绍一种整体导入和导出H3C交换机配置的方法。 本次实验采用的设备和软件有:H3