交换机如何配置OSPF?

腾讯视频/爱奇艺/优酷/外卖 充值4折起

一、组网需求

配置OSPF动态路由协议,让全网可以互通

     二、组网拓扑

三、配置要点

  • 根据规划,在设备接口上配置IP地址
  • 配置OSPF进程
  • 所有区域(area)必须与区域 0(area 0)相连接

四、配置步骤

注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet(千兆)和TenGigabitEthernet(万兆),以下配置以千兆接口为例

1)根据规划,在设备接口上配置IP地址

SWA配置:

Ruijie(config)#interface GigabitEthernet 0/1

Ruijie(config-if-GigabitEthernet 0/1)#no switchport------>把接口属性改成路由接口

Ruijie(config-if-GigabitEthernet 0/1)#ip address 192.168.1.1 255.255.255.0  ------>配置IP地址

Ruijie(config)#interface Loopback 0   ------>作为OSPF的router-id

Ruijie(config-Loopback 1)#ip address 172.16.1.1 255.255.255.0

SWB配置:

Ruijie(config)#interface GigabitEthernet 0/1

Ruijie(config-if-GigabitEthernet 0/1)#no switchport

Ruijie(config-if-GigabitEthernet 0/1)#ip address 192.168.1.2 255.255.255.0

Ruijie(config)#interfaceGigabitEthernet 0/2

Ruijie(config-GigabitEthernet 0/2)#no switchport

Ruijie(config-GigabitEthernet 0/2)#ip address 192.168.2.2 255.255.255.0

Ruijie(config)#interfaceGigabitEthernet 0/3

Ruijie(config-GigabitEthernet 0/3)#no switchport

Ruijie(config-GigabitEthernet 0/3)#ip address 192.168.3.2 255.255.255.0

Ruijie(config)#interface Loopback 0

Ruijie(config-Loopback 0)#ip address 172.16.1.2 255.255.255.0

SWC配置 :

Ruijie(config)#interface GigabitEthernet 0/1

Ruijie(config-if-GigabitEthernet 0/1)#no switchport

Ruijie(config)#ip address 192.168.2.1 255.255.255.0

Ruijie(config)#interface Loopback 0

Ruijie(config-Loopback 0)#ip address 172.16.1.3 255.255.255.0

SWD配置 :

Ruijie(config)#interface GigabitEthernet 0/1

Ruijie(config-if-GigabitEthernet 0/1)#no switchport

Ruijie(config)#ip address 192.168.3.1 255.255.255.0

Ruijie(config)#interface Loopback 0

Ruijie(config-Loopback 0)#ip address 172.16.1.4 255.255.255.0

2)配置OSPF进程

SW A配置:

Ruijie(config)#router ospf 10   ------>开启ospf 10 进程

Ruijie(config-router)#network 192.168.1.0 0.0.0.255 area 0    ------>把包含192.168.1.0 /24的网络划入区域 0

SW B配置:

Ruijie(config)#router ospf 10

Ruijie(config-router)#network 192.168.1.0 0.0.0.255 area 0

Ruijie(config-router)#network 192.168.2.0 0.0.0.255 area 1

Ruijie(config-router)#network 192.168.3.0 0.0.0.255 area 2

SW C配置:

Ruijie(config)#router ospf 10

Ruijie(config-router)#network 192.168.2.0 0.0.0.255 area 1

SW D配置:

Ruijie(config)#router ospf 10

Ruijie(config-router)#network 192.168.3.0 0.0.0.255 area 2

3)保存配置

Ruijie(config-router)#end

Ruijie#write         ------>确认配置正确,保存配置

五、验证命令:

Ruijie#show ip route

Codes:  C - connected, S - static, R - RIP, B - BGP

O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default

Gateway of last resort is no set

C    172.16.1.0/24 is directly connected, Loopback 0

C    172.16.1.1/32 is local host.

C    192.168.1.0/24 is directly connected, GigabitEthernet 0/1

C    192.168.1.2/32 is local host.

O IA 192.168.2.0/24 [110/2] via 192.168.1.1, 00:55:30, GigabitEthernet 0/1  ------>O 表示OSPF学到的路由,O IA表示学到其他区域(area)路由条目

O IA 192.168.3.0/24 [110/2] via 192.168.1.1, 00:56:06, GigabitEthernet 0/1

Ruijie# show ip ospf neighbor     ----查看OSPF邻居状态

OSPF process 10, 1 Neighbors, 1 is Full:

Neighbor ID     Pri   State                Dead Time   Address         Interface

172.16.1.2        1     Full/BDR             00:00:38    192.168.1.1     GigabitEthernet 0/1

中兴,华为,烽火交换机常用配置参考

11/14 17:19
ZXDSL8210常用命令 查看板卡类型和软硬件版本号 showcard 进入DSL模式 dsl 查看端口状态 showinfo 查看ADSL速率摸板 showprof 更改端口应用的速率摸板 linecfg 查看ADSL端口的线路质量 showperf 打开ADSL端口 enable 关闭ADSL端口 disable 重启ADSL端口 resetport 进入atm atm 在atm下查看PVC showvcx all ZXDSL8220常用命令 查看板卡类型和软硬件版本号 sh card 查

思科交换机密码配置和清除操作步骤

11/11 14:39
思科交换机密码配置 一.设置console密码 >enable #configure trminal (confing)#line console 0←console口 ①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码设置完成 exit 二:设置全局密码 enadle #configure terminal ②(config)#enable secret (class)←密码 (config

网管型交换机使用配置和相关技巧

05/30 01:57
网管型交换机的配置问题一直是令许多人为之着迷的,不仅是对一般的用户,对于许多专业的用户也同样是个疑问,同时也是作为网管水平高低衡量的一个重要而又基本的标志。 这主要在两个原因,一是绝大多数企业所配置的交换机都是桌面非网管型交换机,根本不需任何配置,纯属“傻瓜”型,与集线器一样,接上电源,插好网线就可以正常工作; 另一方面多数中、小企业老总对自己的网管员不是很放心,所以即使购买的交换机是网管型的,也不让自己的网管人员来配置,而是请厂商工程师或者其它专业人员来配置,所以这些中、小企业网管员也就很

网管型交换机使用配置技巧

06/06 07:41
网管型交换机的配置问题一直是令许多人为之着迷的,不仅是对一般的用户,对于许多专业的用户也同样是个疑问,同时也是作为网管水平高低衡量的一个重要而又基本的标志。 这主要在两个原因,一是绝大多数企业所配置的交换机都是桌面非网管型交换机,根本不需任何配置,纯属“傻瓜”型,与集线器一样,接上电源,插好网线就可以正常工作; 另一方面多数中、小企业老总对自己的网管员不是很放心,所以即使购买的交换机是网管型的,也不让自己的网管人员来配置,而是请厂商工程师或者其它专业人员来配置,所以这些中、小企业网管员也就很

5种常用的交换机SNMP配置命令

02/04 10:49
SNMP协议在交换机中的运用相信大家不会陌生,所以我们现在就来详细讲解5个基本用到的交换机SNMP配置命令。交换机SNMP配置命令的完成是大家经常遇到的问题,怎样去完成交换机SNMP配置命令,它还有什么相关的口令等等问题,都将在本文中得到全面的解决。 交换机SNMP配置命令(1):snmp-agent sys-info contact 设置管理员的标识及联系方法,请把替换为你要设置成的值,下同。这个值初始是HuaWei BeiJing China,用指令display current-con

交换机TRUNK配置的问题

03/13 23:48
 到底什么是TRUNK呢?使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的交换机产品中怎样来交换机TRUNK配置,下面我们来了解一下这些方面的知识。在二层交换机的性能参数中。 常常提到一个重要的指标:TRUNK,许多的二层交换机产品在介绍其性能时,都会提到能够支持TRUNK功能,从而可以为互连的交换机之间提供更好的传输性能。那到底什么是TRUNK呢? 使用TRUNK功能到底能给我们带来哪些应用方面的优势?还有在具体的交换机产品中怎样来交换机TRUNK配置。下面我们来了解一下

H3C交换机如何配置的备份与恢复

05/02 18:06
局域网维护中,有时候我们需要对网络设备的配置进行备份与还原。 相信有很多网管员备份配置都是采用display current命令查询当前设备运行配置信息,然后采用ctrl+c,ctrl+v的方式将信息保存到txt文档中;或者直接用捕捉屏幕输出的方法保存信息。 还原的时候再复制命令到交换机中从新运行。这种方法当然也是可行的,但是当交换机的配置特别多,又比较复杂的情况下,这种方法就不太合适了。 下面我介绍一种整体导入和导出H3C交换机配置的方法。 本次实验采用的设备和软件有:H3

交换机怎么配置

05/05 22:03
下面以思科"Catalyst 1900"为例来说明如何进行交换机软件配置: 第1步:单击"开始"按钮,在"程序"菜单的"附件"选项中单击"超级终端",弹出如图所示界面. 第2步:双击"Hypertrm"图标,弹出如图所示对话框.这个对话框是用来对立一个新的超级终端连接项. 第3步:在"名称"文本框中键入需新建超的级终端连接项名称,这主要是为了便于识别,没有什么特殊要求

Win7系统交换机如何配置?

09/12 11:54
Win7系统交换机如何配置? 操作方法如下: 1.单击"开始"按钮,在"程序"菜单的"附件"选项中单击"超级终端"; 2.双击"Hypertrm"图标,弹出如图5所示对话框.这个对话框是用来对立一个新的超级终端连接项; 3.在"名称"文本框中键入需新建超的级终端连接项名称,这主要是为了便于识别,没有什么特殊要求,我们这里键入"Cisco",如果您想为这个连接项选择一个