华为S8500交换机实现灵活QinQ的配置原理

腾讯视频/爱奇艺/优酷/外卖 充值4折起

一、简单原理介绍
使用普通的QinQ虽然可以解决VLAN的扩展和简单二层VPN的功能,但对一个端口只能增加固定的外层TAG,无法满足对不同业务的用户增加不同外层VLAN TAG的要求。如VLAN 100~200为一种业务的用户,要求打上外层标签10;VLAN 201~300为另一业务,要求打上外层标签20;VLAN 10~20的业务要求不打标签,这种应用需求QinQ就无法做到。
灵活QINQ可以通过配置特定的ACL规则,让匹配ACL规则的报文增加我们指定的vlan tag或把进入的报文的vlan tag修改成我们指定的vlan tag,来达到我们灵活应用的目的。

二、S8500典型配置实例
2.1 组网需求
下图网中,DSLAM上通过VLAN隔离每个用户,VLAN 1000~2999为普通上网业务,要求到达S8500后增加外层tag 10送BRAS处理。BTV业务由GSR通过vlan 3000送到DSLAM,由DSLAM进行组播复制,把组播流复制到用户vlan。
这样要求S8500需要对g2/1/1端口进入的vlan为1000~2999的报文增加tag 10后通过vlan 10转发到BRAS。VLAN 3000进入的报文则不增加tag,可以在vlan 3000进行二层组播报文转发。对这种要求85可以通过根据ACL规则对不同的vlan增加不同tag的方法实现。
DSLAM设置上网用户映射到vlan 1000~2999;配置组播vlan 3000,组播子vlan为vlan 1000-2999;上行口连接S8500,要求允许vlan 1000~3000通过。
2.2 组网图

2.3 配置命令
8500的基本配置:
# 配置匹配vlan 1000~2999的ACL
[S8500] acl number 4000
[S8500-acl-link-4000]rule 0 permit ingress 1000 to 2999
[S8500]vlan 10 3000
# 配置连接DSLAM的端口,端口允许VLAN 10和VLAN 3000通过,取消端口的VLAN过滤属性,配置nested-vlan使匹配ACL 4000规则的报文增加vlan tag 10
[S8500]interface GigabitEthernet 2/1/1
[S8500-GigabitEthernet2/1/1]port link-type hybrid
[S8500-GigabitEthernet2/1/1]port hybrid vlan 10 untagged
[S8500-GigabitEthernet2/1/1]port hybrid vlan 3000 tagged
[S8500-GigabitEthernet2/1/1]vlan filter disable
[S8500-GigabitEthernet2/1/1]traffic-redirect inbound link-group 4000 rule 0
nested-vlan 10

# 分别配置连接GSR和BRAS的端口
[S8500]interface g2/1/2
[S8500-GigabitEthernet2/1/2]port link-type trunk
[S8500-GigabitEthernet2/1/2]port trunk permit vlan 3000
[S8500-GigabitEthernet2/1/2]interface g2/1/3
[S8500-GigabitEthernet2/1/3]port link-type trunk
[S8500-GigabitEthernet2/1/3]port trunk permit vlan 10

# 在VLAN 3000上启用二层组播
[S8500]igmp-snooping enable
[S8500]vlan 3000
[S8500-vlan3000]igmp-snooping enable
配置BRAS和GSR设备:
配置BRAS可以处理带双vlan tag 的报文,并终结PPPOE报文。配置GSR启用三层组播,作为组播路由器。

H3C交换机基于MAC地址VLAN配置教程

11/27 17:29
对于不是很常用的MAC VLAN,许多读者都感到很陌生,读者QQ群中也经常见到有读者提到这方面的问题,希望我给予解答。现从笔者编著,目前在全国热销的《Cisco/H3C交换机配置与管理完全手册》(第二版)(与之配套的姊妹篇为《Cisco/H3C交换机高级配置与管理技术手册》)一书中摘选一部分H3C交换机MAC VLAN内容,希望对这些读者有所帮助。如要全面了解Cisco和H3C交换机的MAC VLAN相关知识和配置方法,请参见Cisco/H3C交换机配置与管理完全手册》(第二版)。 19.6 H

中兴,华为,烽火交换机常用配置参考

11/14 17:19
ZXDSL8210常用命令 查看板卡类型和软硬件版本号 showcard 进入DSL模式 dsl 查看端口状态 showinfo 查看ADSL速率摸板 showprof 更改端口应用的速率摸板 linecfg 查看ADSL端口的线路质量 showperf 打开ADSL端口 enable 关闭ADSL端口 disable 重启ADSL端口 resetport 进入atm atm 在atm下查看PVC showvcx all ZXDSL8220常用命令 查看板卡类型和软硬件版本号 sh card 查

华为交换机配置命令 华为QuidWay交换机配置命令手册

01/31 22:13
1、开始建立本地配置环境,将主机的串口通过配置电缆与以太网交换机的Console口连接。 在主机上运行终端仿真程序(如Windows的超级终端等),设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100。 以太网交换机上电,终端上显示以太网交换机自检信息,自检结束后提示用户键入回车,之后将出现命令行提示符(如<Quidway>)。 键入命令,配置以太网交换机或查看以太网交换机运行状态。需要帮助可以随时键入"?" 2、命令视图

H3C交换机典型(ACL)访问控制列表配置实例

11/23 01:12
一、组网需求: 1.通过配置基本访问控制列表,实现在每天8:00~18:00时间段内对源IP为10.1.1.2主机发出报文的过滤; www. 2.要求配置高级访问控制列表,禁止研发部门与技术支援部门之间互访,并限制研发部门在上班时间8:00至18:00访问工资查询服务器; 3.通过二层访问控制列表,实现在每天8:00~18:00时间段内对源MAC为00e0-fc01-0101的报文进行过滤。 二、组网图: 三、配置步骤: H3C 3600 5600 5100系列交换机典型访问控制列表配置 共用配

华为H3C交换机路由器命名规则详解

11/14 06:40
一、设备版本规则 LI(Lite software Image)表示设备为弱特性版本。 SI(Standard software Image)表示设备为标准版本,包含基础特性。 EI(Enhanced software Image)表示设备为增强版本,包含某些高级特性。 HI(Hyper software Image)表示设备为高级版本,包含某些更高级特性。 PWR 表示设备为支持远程以太网供电,供电符合802.3AF标准。 二、性能命名规则 Quidway SA1 A2 A3 A4 A5-A6

交换机如何做最基本配置与管理

04/06 00:12
某公司新进一批交换机,在投入网络以后要进行初始配置与管理,你作为网络管理员,对交换机进行基本的配置与管理. 一.交换机的管理方式基本分为两种:带内管理和带外管理. 1.通过交换机的Console端口管理交换机属于带外管理;这种管理方式不占用交换机的网络端口,第一次配置交换机必须利用Console端口进行配置. 2.通过Telnet.拨号等方式属于带内管理. 二.交换机的命令行操作模式主要包括: 1.用户模式 Switch> 2.特权模式 Switch# 3.全局配置模式 Switch(confi

华为2403交换机开启SNMP的命令

05/08 08:43
snmp-agent snmp-agent community read gwidc acl 2000 snmp-agent community write gwidc acl 2000 snmp-agent sys-info version all 以下是补充:snmp-agent snmp-agent community write gzgy@))* snmp-agent sys-info version all snmp-agent target-host trap address udp

Netapp网卡与外联交换机的接法与配置教程

11/10 01:43
1, Netapp 网卡设定类别: a. single mode 通常2个接口作single mode,分别连接外部2台交换机,同一时刻只有一个端口有数据流.(NA自己的single mode冗余作用) b.multi mode 通常2个接口做multi mode,与外部1台或stack 2台交换机相连,同一时刻,2个端口都有数据流.(双端口线路冗余) c.lacp mode 通常2个或4个接口作multi mode 与外部1台或stack2台交换机相连接,同一时刻所有端口都有数据流.(双端口线

华为S5700怎么划分VLAN? S5700交换机配置VLAN的方法

10/03 17:21
<Huawei>system-view 进入配置模式 Enter system view, return user view with Ctrl+Z. [Huawei]sysname center_switch 更改交换机名 创建vlan [center_switch]vlan 40 [center_switch-vlan40]quit 给vlan配置IP地址 [center_switch]interface Vlanif 40 [center_switch-Vlanif40]ip